แจก Script สำหรับ Backup ไฟล์ Config Mikrotik ขึ้น Cloud ของ Mikrotik โดยอัตโนมัติ

1268

ใน Mikrotik RouterOS 6.48.4 และ RouterOS 7rc1 มีการเพิ่มความสามารถ Cloud Backup ขึ้นมาให้เราใช้งานนะครับ โดยที่ความสามารถนี้ จะให้เราสามารถโยน Backup File ของ Mikrotik ขึ้นไปเก็บบน Cloud ของทาง Mikrotik ได้จำนวน 1 ไฟล์ด้วยกัน

 

ซึ่งไฟล์ Backup นี้ จะเป็นไฟล์ที่ใช้ในการ Restore Config ของคุณกลับมาที่ อุปกรณ์ที่สร้างไฟล์นี้ขึ้นเท่านั้นนะครับ ไม่ใช่ไฟล์ที่จะไป Restore เครื่องไหนก็ได้

ทีนี้ ถ้าให้เรามานั่งกด Backup เองทุกวัน ก็คงมีลืมกันบ้างแหละ

ผมเลยทำ Script ขึ้นมา 2 ตัว ชื่อว่า

  • create-cloud-backup
  • delete-cloud-backup

โดยที่หน้าที่ของมันก็สามารถดูได้จาก Script เลยครับ อันนึงทำหน้าที่ลบไฟล์ อีกอันทำหน้าที่สร้างไฟล์แล้วโยนขึ้นไป ซึ่ง ก็สามารถตั้ง schedule ได้ว่า จะให้มันทำงานตอนกี่โมง ซึ่งถ้าใช้ script ของผม มันจะทำ delete-cloud-backup ตอน ตี 3 ตรง 

แล้วตอน 3:01 ก็จะสร้าง Backup File แล้วโยนขึ้นไปโดยอัตโนมัติครับ

ทีนี้ การสร้าง Backup File แล้วโยนขึ้นไปใน Cloud ของ Mikrotik จะต้องมีการกำหนด password เพื่อใช้ตอน Restore ด้วย ซึ่ง ก็ไปแก้ไขเป็น Password ของใครของมันกันเอาเองนะครับ ค่า default ผมตั้งเป็น your-recovery-password ครับ

Requirement ก่อนที่จะใช้ Script นี้

  1. Mikrotik ของคุณจะต้องใช้เวอร์ชั่น 6.48.4 หรือ RouterOS 7rc1 ขึ้นไป
  2. อย่าลืมตั้งค่า Recovery Password ด้วย 
  3. ก็อป text นี้ แล้วแปะลงหน้า terminal ของ mikrotik ด้วย การใช้คลิกขวา แล้ว paste นะครับ ใช้ ctrl+v ไม่ได้นะครับ
#Script-cloud-backup
/system script add dont-require-permissions=yes name=create-cloud-backup owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source="/system backup cloud upload-file src-file=backup password=your-recovery-password action=create-and-upload\r\
    \n:delay 3s\r\
    \n:log info message=\"Finish Upload New Cloud Backup\" \r\
    \n"
/system script add dont-require-permissions=yes name=delete-cloud-backup owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source="/system backup cloud print\r\
    \n:delay 3s\r\
    \n/system backup cloud remove-file number=0\r\
    \n:delay 3s \r\
    \n:log info message=\"Finished Delete Cloud Backup\""
/system scheduler add interval=1d name=delete-cloud-backup on-event=delete-cloud-backup policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-time=03:00:00
/system scheduler add interval=1d name=create-cloud-backup on-event=create-cloud-backup policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-time=03:01:00